EOS Get Started

使用Epic在线服务(EOS)SDK快速设置并运行游戏。

阅读时间5分钟

要使用 Epic 在线服务(EOS),你需要下载EOS SDK。为此,你需要;

  • 设置开发者帐户,然后下载SDK
  • 下载EOS SDK

Epic Games同时提供一个示例项目,展示游戏接入EOS的各类方式。

设置帐户

你可以通过开发者门户(dev.epicgames.com/portal)来设置游戏如何使用EOS服务,并配置相关服务。
在开发者门户中,所有游戏都被视为一个“产品”。每个产品拥有一个 产品Id、一个 沙盒Id 和 一个 部署Id。EOS SDK通过它们来确定你的游戏以及对应的EOS服务。

如需进一步了解如何在设置账号时使用产品管理工具,请参阅开发者门户中的文档产品、沙盒和部署ID

下载EOS SDK

设置好组织和产品后,你可以在开发者门户中下载EOS SDK。SDK允许你访问EOS的各项功能和服务,例如指标集合和用户身份验证。在SDK下载包中,你会找到以下目录:

目录内容
/SDK/关联产品所需的库和标头文件
/样本/展示SDK工作原理的样本应用程序
/第三方申明/关于各种支持库的法律信息
欲了解EOS SDK的相关详情,参见在线文档。Epic Games同时提供开发者论坛,以便您加入EOS开发者社区并提交疑问。

根据你的游戏客户端运行的平台,我们提供了不同类型的SDK供下载:

  • **Windows、macOS、Linux - EOS SDK(C版本),以及EOS SDK(C#版本)。
  • **移动端 - EOS SDK(iOS版本),以及EOS SDK(安卓版本)。
  • **主机端 - 为游戏主机平台提供了EOS SDK(C版本)、以及EOS SDK(C#版本)的下载。 主机端的SDK下载只提供给那些通过平台持有者和Epic Games批准的开发者。 平台持有者是指:微软(Xbox One、Xbox Series X)、索尼(PlayStation 4、PlayStation 5)、任天堂(Switch)。 如需下载主机版本的SDK并获得相关文档:
    • 查阅开发者门户(dev.epicgames.com/dev-portal) ,了解如何向平台持有者申请主机开发者权限。
    • 获得平台持有者批准后,你可以使用 EOS主机开发者申请 表格,向Epic Games进行申请。该表格位于eoshelp.epicgames.com..

提示:你可以使用开发者论坛提出问题,获取支持,并加入EOS开发者社区。

试用示例

下载SDK后,可找到展示平台各类功能的[样本游戏](样本)。这些样本将展示每种功能的正确运行方式。有关更多详情,请参见以下文档:

EOS SDK依赖项

下文各小节介绍了各个平台上使用EOS SDK开发和发布产品时所需满足的要求,例如操作系统版本和需要安装的软件包。

SDK示例

开发(示例)
需要安装的软件Visual Studio 2017 或更高版本

Windows

发布
操作系统Windows 7及其之后的版本
EOS SDKEOS SDK 二进制文件(DLL)
需要安装的软件最新发布的Microsoft Visual C++ Redistributable;应用程序需要 MSVCP140.dll

Linux

开发
操作系统最新发布的 x86 或 x64 发行版本
需要安装的软件gcc 或 Clang 编译器
其他编译器也许可以工作,但未经测试。
需要安装的软件cmake 2.6 或更高版本

Mac

开发(推荐)
操作系统macOS Catalina(10.15.4)或更高版本
需要安装的软件Xcode 12.4或更高版本
发布
操作系统macOS Sierra(10.12)或更高版本(基于英特尔芯片的Mac) macOS Big Sur(11.0)或更高版本(基于Apple芯片的Mac)

iOS

开发
操作系统iOS 11 或更高版本;推荐使用iOS 12 或更高版本
需要安装的软件适用于iOS 12及更高版本的验证服务框架(AuthenticationServices)
需要安装的软件适用于iOS 11的Safari服务框架
发布
操作系统iOS 11 或更高版本;推荐使用iOS 12 或更高版本
需要安装的软件适用于iOS 12及更高版本的验证服务框架(AuthenticationServices)
需要安装的软件适用于iOS 11的Safari服务框架

Android

开发
操作系统Android OS 6.0 或更高版本 (SDK 级别 23)
需要安装的软件ARM v7 或 ARM v8-a
ARM v7尚未使用罪行版本进行测试

主机

PlayStation 4

开发
需要安装的软件PlayStation 4 SDK 7.508
需要安装的软件Visual Studio 2017 或更高版本

PlayStation 5

开发
需要安装的软件PlayStation 5 SDK 2.00
需要安装的软件Visual Studio 2017 or higher

Xbox One

开发
需要安装的软件XDK July 2018 QFE13
需要安装的软件Visual Studio 2017 或更高版本

Xbox Series X 和 Xbox One (GDK)

开发
需要安装的软件GDK June 2020 GDK QFE 2
需要安装的软件Visual Studio 2019 or higher

任天堂Switch

开发
需要安装的软件任天堂Switch SDK 9.3.1
需要安装的软件Visual Studio 2017 或更高版本